반응형

[2438]별 찍기 - 1

예제 입력 1 
5

예제 출력 1 
*
**
***
****
*****
#include <bits/stdc++.h>
using namespace std;
int main()
{
  int N;
  cin >> N;

  for(int i=1; i<=N; i++){
    for(int j=1; j<=i; j++){
       printf("*");
    }
    cout << endl;
  }
  return 0;
}

 

[2439]별 찍기 - 2

예제 입력 1 
5
예제 출력 1 
    *
   **
  ***
 ****
*****
#include <bits/stdc++.h>
using namespace std;

int main()
{
  int N;
  cin >> N;

  for(int i=1; i<=N; i++){
    for(int k=1; k<=N-i; k++){
      cout << " ";
    }
    for(int j=1; j<=i; j++){
      cout << "*";
    }
    cout << endl;
  }
  return 0;
}

[2440]별 찍기 - 3

예제 입력 1 
5
예제 출력 1 
*****
****
***
**
*
#include <bits/stdc++.h>
using namespace std;

int main()
{
  int N;
  cin >> N;

  for(int i=0; i<N; i++){
    for(int j=0; j<N-i; j++){
      cout << "*";
    }
    cout << endl;
  }
  return 0;
}

[2441]별 찍기 - 4

예제 입력 1 
5
예제 출력 1 
*****
 ****
  ***
   **
    *
#include <bits/stdc++.h>
using namespace std;

int main()
{
  int N;
  cin >> N;

  for(int i=0; i<N; i++){
    for(int k=0; k<i; k++){
      cout << " ";
    }
    for(int j=0; j<N-i; j++){
      cout << "*";
    }
    cout << endl;
  }
  return 0;
}

[2442]별 찍기 - 5

예제 입력 1 
5
예제 출력 1 
    *
   ***
  *****
 *******
*********

 

#include <bits/stdc++.h>
using namespace std;

int main()
{
  int N;
  cin >> N;

  for(int i=1; i<=N; i++){
    for(int k=1; k<=N-i; k++){
      cout << " ";
    }
    for(int j=1; j<=2*i-1; j++){
      cout << "*";
    }
    cout << endl;
  }
  return 0;
}

[2443]별 찍기 - 6

예제 입력 1 
5
예제 출력 1 
*********
 *******
  *****
   ***
    *
#include <bits/stdc++.h>
using namespace std;

int main()
{
  int N;
  cin >> N;

  for(int i=0; i<N; i++){
    for(int k=0; k<i; k++){
      cout << " ";
    }
    for(int j=0; j<2*(N-i)-1; j++){
      cout << "*";
    }
    cout << endl;
  }
  return 0;
}

[2444]별 찍기 - 7

예제 입력 1 
5
예제 출력 1 
    *
   ***
  *****
 *******
*********
 *******
  *****
   ***
    *
반응형

'Algorithm > 구현-기하학' 카테고리의 다른 글

[c++]baekjoon 2477 참외밭  (0) 2021.06.05
[c++]baekjoon 2166 다각형의 면적  (0) 2021.06.05

+ Recent posts